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Prevent CAB and Seagull Driver Packages from Automatically Associating With Brady Printers

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Content

 
Article Number000012040
TitlePrevent CAB and Seagull Driver Packages from Automatically Associating With Brady Printers
Body
Issue

Driver packages required for a specific printer often support additional printer models, these driver packages can automatically associate when a new supported printer model is connected to the same PC. While often convenient, there are limited use cases where a user may want to control which specific driver versions are used with specific printers to avoid print position or print communication issues. This process is often required when using CAB or Seagull driver packages. 

Example:

The BBP11 and BBP12 use the Seagull driver package, this package also supports IP, PR and i7100 series printer models. This means the package will automatically assign the Seagull driver to the IP, PR and i7100 printer models when they are connected to the PC. If the user has Brady Workstation and wants to connect all these printers to the same PC, they will want the Seagull driver for the BBP11/12, the 4.6.21 Brady signed driver for the PR series, the 3.10 Brady driver for the IP Series, and the CAB 5.2 driver for the i7100 printer. 


Cause

Windows 10 attempts to make driver installation more convenient by making some assumptions about your driver needs. When a new printer is connected to your PC: 

1. Windows automatically searches it's own catalog for a compatible driver.
2. If Windows does not find an appropriate driver, Windows then goes into the FileRepository folder on the local PC to see if the user already installed a compatible driver.
3. Windows searches the .inf folder list alphabetically and auto-associates the first .inf folder offering a compatible driver.
4. CAB and Seagull packages start with "bradyoem.inf" and "brady.inf" respectively, so they are often chosen before Brady driver .inf packages. 


Workaround

1. First, install the driver package for the printer that requires the version offered by that driver package. In our example above, this would be the BBP11 or BBP12 printer using the Seagull driver package. 

2. Confirm everything works as expected, the BBP11 or BBP12 can communicate with the software and print without issues, etc. 

3. Now navigate to C:\Windows\System32\DriverStore\FileRepository and locate the file from Seagull that starts with "brady.inf", or look for the folder that starts with "bradyoem.inf" if you used a CAB driver package in step 1. 


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4. Delete the driver package folder. This will not affect the driver that is already associated with the printer you setup in the first step. The FileRepository folder only holds driver "backups". This does require administrative rights on your system, so reach out to your IT admin if necessary. 

5. Now connect and install the appropriate driver package for your additional printers. 



Alternative Method

You can also navigate to Devices and Printers > Printer Properties > Advanced Tab and change the driver used. While this process is more simple, we have found it may be less reliable than removing the .inf driver package from FileRepository. 

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See Also
 
URL NamePrevent-CAB-and-Seagull-Driver-Packages-from-Automatically-Associating-With-Brady-Printers

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