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GHS Freezes and Crashes When After Copying the GHS.Database to a New PC

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Content

 
Article Number000011311
TitleGHS Freezes and Crashes When After Copying the GHS.Database to a New PC
Body
Symptoms

A user attempts to copy a database sdf file as outlined in Brady Workstation - Creating a Backup of the GHS Database, however GHS freezes or crashes when starting the app or attempting to select a chemical from the list. 

Cause

Offline GHS installations are less likely to be updated. This means there will be a version difference when moving your GHS database to a new PC. Older versions of GHS do not have the "Export Chemicals" button.



Workarounds

This means the database must be moved by copying the GHSdatabase.sdf file between installations.
  • Note: We recommend copying your .sdf database to a USB drive or network storage prior to attempting these steps. 
Method 1

Only use this method if the original PC is running Brady Workstation Shell version 3.0 or newer. Older versions will not allow a direct update. 

1. Compare the storageVersion number between your GHS installations.

The GHS database version can be viewed in the StorageMetadata.xml file at this location: C:\ProgramData\Brady Corp\Brady Workstation\AddinsData\Ghs

See <storageVersion>




2. Download and install the latest version of the Brady Workstation Shell and GHS app on the PC running the older installation: Brady Workstation - How to Download and Install the Software and Apps from the Web

3. Transfer the .sdf file to the new PC. 
On the original PC, navigate to C:\ProgramData\Brady Corp\Brady Workstation\AddinsData\Ghs and copy and paste GHS.Database.sdf to USB storage. 

4. Close Brady Workstation on the new PC. Navigate to C:\ProgramData\Brady Corp\Brady Workstation\AddinsData\Ghs and copy your saved GHS.Database file from USB storage to this folder.

5. Launch Brady Workstation and the GHS app. All chemicals should now appear. If the software continues to crash, try Method 3. 

Method 2

Use this method if GHS will crashes after copying the sdf file to the new PC, or if the original PC is running Brady Workstation shell older than version 3.0. 

1. On the original PC, navigate to Navigate to C:\ProgramData\Brady Corp\Brady Workstation\AddinsData\Ghs and copy your saved GHS.Database file to external USB. 

2. Keep Brady Workstation and the GHS app running on the new PC. Navigate to C:\ProgramData\Brady Corp\Brady Workstation\AddinsData\Ghs and copy your saved GHS.Database file from USB storage to this folder.

3. Navigate and click around in the GHS app to refresh the product list. GHS will likely freeze at this point.

4. Wait for a minute or two, then close and relaunch Brady Workstation and the GHS app. The database should be refreshed at this point. If the software continues to crash, try Method 3. 

Method 3

Use this method if you are successful in copying the sdf to the new PC and all products appear in GHS on the new PC (steps 3 and 4 of Method 1), however selecting any of the chemicals to make a label causes GHS to freeze and crash. 

1. After copying the GHS.Database.sdf into the correct folder path on the new PC, choose "Export chemicals". This will generate an Excel file with all the chemicals. 

2. When chemical export completes, close the software. On the new PC where you just generated the Excel sheet, Navigate to C:\ProgramData\Brady Corp\Brady Workstation\AddinsData\Ghs and delete GHS.Database.sdf. 

3. Launch Brady Workstation and the GHS app. Select "Import Data" on the left column. 

4. Select the "Select Excel File" button on the upper left and navigate to the "GhsProductsExcelExport.xlsx" file you created in step 1. All chemicals should now import without issue.




 
URL NameTransferring-GHS-Database-SDF-Files-From-Old-GHS-Installations

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